Welcome, Guest
Username: Password: Secret Key Remember me
Welcome to the Joomla Extensions forum!

Tell us and our members who you are, what you like and why you became a member of this site.
We welcome all new members and hope to see you around a lot!

TOPIC: Encrypt configuration fails to work after backup

Encrypt configuration fails to work after backup 06 Aug 2015 12:08 #3131

  • rokkhit
  • rokkhit's Avatar
  • Offline
  • New Member
  • Posts: 3
Hi
First of all I must say that your Encrypt configuration extension is just great.
It worked nicely without any hitch until recently when I backed-up my site with Akeeba Backup and then restored it again with the tools provided by Akeeba Backup.
After the site was restored, I could not login to the site both as the administrator and as a general user, with the login credentials which I had been using for so long.

I am using Joomla! 3.4.3 and the latest version of Encrypt configuration (com_encrypt_3.5).

Please help me on this urgently as I am unable to access my site's backend.

Regards,
Rokkhit
The administrator has disabled public write access.

Encrypt configuration fails to work after backup 06 Aug 2015 12:57 #3132

  • Ratmil
  • Ratmil's Avatar
  • Offline
  • Administrator
  • Posts: 1487
  • Thank you received: 25
Hi, Rokkhit.
You must have a way to access your site database. It should be a mySQL database.
There go to table #__extensions. Find a record where name = 'system - encrypt'. Edit that record and set enabled to 0. If the problem is the extension then you should be able to login again. Then you can uninstall and then re-install again if you want.
If I don't provide the answers you are looking for, I may provide the questions you need to find the answers yourself.
The administrator has disabled public write access.

Encrypt configuration fails to work after backup 06 Aug 2015 13:11 #3133

  • rokkhit
  • rokkhit's Avatar
  • Offline
  • New Member
  • Posts: 3
Hi,
Thank you for your tips. I was able to login to my site.
Now, the question that remains is how to solve the problem with backup and restore of the site.
Please enlighten me on this.
The administrator has disabled public write access.

Encrypt configuration fails to work after backup 06 Aug 2015 13:39 #3134

  • Ratmil
  • Ratmil's Avatar
  • Offline
  • Administrator
  • Posts: 1487
  • Thank you received: 25
I really don't know why you weren't able to login. I have never used Akeeba Backup, I am not saying that it is something wrong with the backup.
Did you solve the way I told you?
If I don't provide the answers you are looking for, I may provide the questions you need to find the answers yourself.
The administrator has disabled public write access.

Encrypt configuration fails to work after backup 06 Aug 2015 13:45 #3135

  • rokkhit
  • rokkhit's Avatar
  • Offline
  • New Member
  • Posts: 3
Do you mean the uninstall and install again step?
No I have not done it yet, because of the present users accounts.
Will not there be any problem with those users who have already have their passwords encrypted in the database?
The administrator has disabled public write access.

Encrypt configuration fails to work after backup 06 Aug 2015 14:14 #3136

  • Ratmil
  • Ratmil's Avatar
  • Offline
  • Administrator
  • Posts: 1487
  • Thank you received: 25
No, there won´t be a problem.
Encryption Configuration doesn´t encrypt passwords in database. They are already encrypted by Joomla using md5.
What the plugin does is encrypting the transmission of passwords from client browser to server.
If I don't provide the answers you are looking for, I may provide the questions you need to find the answers yourself.
The administrator has disabled public write access.
Time to create page: 0.205 seconds
Powered by Kunena Forum