Welcome, Guest
Username: Password: Secret Key Remember me

TOPIC: No emails & no link after successful PayPal paymen

No emails & no link after successful PayPal paymen 28 Mar 2016 19:00 #3354

of course. mail me and I'll reply with the details.
The administrator has disabled public write access.

No emails & no link after successful PayPal paymen 14 Oct 2017 20:03 #3470

  • Miguel
  • Miguel's Avatar
  • Offline
  • New Member
  • Posts: 9
Ratmil:

I've already contacted you before, but I'm still experiencing the same problem described here. I have already tested with several versions of PHP, right now the lowest supported on my server is PHP 5.4.33.

- The payment is done without problem in PayPal.
- Email is not sent with download link
- The purchase is not registered in the backend
- Once the payment is made, give the following message:
"Your download link is not ready because payment was not done. Check your Paypal account or any other gateway you are using. Or contact site administrator".

I will greatly appreciate your help, because I am already desperate.

The data to access the site are the same as I had previously provided. But if you require them again with pleasure I send them by email.

This began to happen from July of this year.

And for now, we have not managed to solve it, my version of Joomla is 3.8.1, PHP 5.4.33 (I would prefer 7.1); MySQL is 5.5 and has SSL.

I also use Securitycheck pro.

Thank you in advance for your support.
The administrator has disabled public write access.

No emails & no link after successful PayPal paymen 16 Oct 2017 15:08 #3471

  • Miguel
  • Miguel's Avatar
  • Offline
  • New Member
  • Posts: 9
Finally and after several tests I managed to find the problem thanks to the help of Ratmil, the problem was a block generated by the PHP module "mod_security", which had a rule blocking the request and therefore processed the payment, but did not send email

Once the rule was disabled everything was resolved.

I must say that we did a lot of testing, including PHP version changes from 7.1 to 5.4 to rule out some problem with PHP. We uninstalled the SSL certificate to rule out that it was not an issue with it.

Only until we monitor the PHP logs, we discover the module lock.

I want to publicly thank Ratmil, who has responded quickly and always showing a great commitment to solve the problem.
Last Edit: 16 Oct 2017 15:10 by Miguel.
The administrator has disabled public write access.
Time to create page: 0.208 seconds
Powered by Kunena Forum